Archive for the ‘Linux’ Category

Correggere i piccoli problemi dopo aver installato i driver Nvidia
lunedì 1 settembre 2008

A volte accade che dopo aver installato il pacchetto nvidia dei repository o, alternativamente, il file .run, si esegue nvidia-xconfig e ci si ritrova la mappatura della tastiera inglese..

Vabè, non è grave, si risolve in fretta, però è leggermente fastidioso..

Terminale! (root)

  • gnome

gedit /etc/X11/xorg.conf

  • kde

kate /etc/X11/xorg.conf

  • xfce

mousepad /etc/X11/xorg.conf

Modificate questa sezione (InputDevice) aggiungendo una riga:

Section “InputDevice”
Identifier     “Keyboard0”
Driver         “kbd”
Option         “XkbLayout” “it”
EndSection

Ah! Se volete levare anche il logo Nvidia all’avvio aggiungete anche quest’altra riga:

Section “Device”
Identifier     “Card0”
Driver         “nvidia”
VendorName     “nVidia Corporation”
BoardName      “G72 [GeForce 7500 LE]”
Option         “NoLogo” “True”
EndSection

P.S: Aggiungete solo la riga che vi serve, ma non modificate gli altri valori perchè cambiano da pc a pc.

Ora salvate e uscite.

Ora riavviate il pc o digitate sempre dal terminale:

/etc/init.d/gdm restart

P.S 2: In alcune distribuzioni (tipo in Arch, ma non parlo di Ubuntu e Debian perchè sono sicuro al 100% che sia così) il comando da fare è

/etc/rc.d/gdm restart

P.S 3: gdm va sostituito in base a quale DE usate (per KDE kdm)

Ora dovrebbe essere tutto a posto..

P.S 4: A me sta cosa è successa con Debian, con le altre distribuzioni non lo so se accade o no, ma credo che con Ubuntu e Arch non capiti proprio..